LX850 Firmware 1.1i Available!


An update to the LX850 firmware (version 1.1i) is now available for download through Meade’s AutoStar Updater 6.1 program. Version 1.1i implements PE sensor detection at startup when the PEC feature is on.

  • Download AutoStar version 6.1 here.
  • Instructions on installing Meade firmware here.
  • Contact Meade customer service here.

LX600 Firmware 1.1i Available!


An update to the LX600 firmware (version 1.1i) is now available for download through Meade’s AutoStar Updater 6.1 program. Version 1.1i improves compatibility with Meade's StellaAccess Wi-Fi device.

  • Download AutoStar version 6.1 here.
  • Instructions on installing Meade firmware here.
  • Contact Meade customer service here.

LX200 Firmware 4.2l Available!


An update to the LX200 firmware (version 4.2l) is now available for download through Meade’s AutoStar Updater 6.1 program. Version 4.2l corrects a bug reported by several users where the STARS catalog was not displaying some stars correctly.

  • Download AutoStar version 6.1 here.
  • Instructions on installing Meade firmware here.
  • Contact Meade customer service here.

GPS Rollover Issue


Some customers have reported an issue with their GPS equipped telescopes getting a GPS fix but reporting an incorrect year.  This is a direct result of the GPS week number rollover issue that occurred globally on April 6, 2019. Please note not all GPS telescopes are affected by this issue.

For those affected by the GPS rollover issue, new telescope firmware can be downloaded and installed into the telescope using the latest Meade AutoStar Updater Program version 6.1.

  • Download AutoStar version 6.1 here.
  • Contact Meade customer service here.

 

Here is a list of the update firmware available for download.

Handbox Type Telescope Models Firmware
AudioStar
(English/Spanish)
LX90 Series A4S4
AutoStar II LX200 Series 4.2k
AutoStar II LX600 Series 1.1h
AutoStar II LX600 – 16” Models Only 1.1i
AutoStar II LX850 Series 1.1h

 

For instruction on installing the telescope firmware and equipment needed click here.